Severity: MinorCurrent status: Resolved
Webhook delivery backlog
- Started
- Duration
- 2 hr 12 min
- Last updated
- Resolved
Affected: Merchant Gateway API, Transactions and Reporting
Resolved
The backlog has cleared and webhooks are delivering in real time again. All queued events were delivered; retries preserved ordering per merchant.
Identified
A merchant endpoint returning very slow responses consumed a disproportionate share of delivery workers. We have isolated that endpoint onto its own queue.
Investigating
Outbound webhook deliveries are running behind. Merchants may receive payment notifications later than usual.