USSD sessions timing out before completion
- Started
- Duration
- 3 hr 50 min
- Last updated
- Resolved
Affected: USSD
Resolved
USSD session completion rates held steady through the peak. Resolved. Customers affected during the window would have seen the session end without a confirmation message; those requests were never submitted and can simply be retried.
Monitoring
We have reduced the middleware response time and shortened our own session timeout so it sits inside the operator's. Completion rates have recovered to normal for the time of day. We are watching through the remainder of the evening peak.
Identified
Our USSD middleware is holding sessions open longer than the network operator's session timeout during the evening peak, so the operator drops the session before the customer can confirm. No transfer is submitted when a session drops at this step, so no customer has been debited without completing their request.
Investigating
Customers using our USSD short code are seeing sessions drop partway through, most often at the point of confirming a transfer. The app, the merchant portal and card payments are unaffected.