POS terminals declining card payments
- Started
- Duration
- 6 hr 5 min
- Last updated
- Resolved
Affected: POS Terminals, Card Processing
Resolved
Card authorisation rates on POS terminals have been at normal levels for over an hour. Resolved. Declined transactions were rejected cleanly at the terminal and no cardholder was charged for a failed sale. Merchants who took payment by mobile money during the window were unaffected.
Monitoring
The certificate has been deployed and terminals are authorising normally again. Terminals reconnect on their next transaction, so no merchant needs to restart a device. We are monitoring authorisation rates across the estate.
Identified
Terminals are failing to complete the authorisation handshake after a certificate on the acquirer connection was rotated. Terminals that were already mid-session continued to work, which is why the impact looked intermittent at first. We are deploying the updated certificate to the terminal gateway.
Investigating
Merchants are reporting that card payments on POS terminals are being declined at the point of sale. Mobile money on terminals, hosted checkout and online card payments are unaffected.